Problem beim Einrichten auf Synology

Support für das kostenlose Rechnungsprogramm (open3A)
Antworten
Zahoernchen
Beiträge: 4
Registriert: 17.Jan.2019, 17:13

Problem beim Einrichten auf Synology

Beitrag von Zahoernchen » 20.Jan.2019, 13:09

Hi :)

habe mich jetzt für open3a entschieden.
Jetzt harperts etwas mit der Einrichtung auf meiner Synology Diskstaion... wahrscheinlich weil mir die Kenntnis fehlt ^.^

Mit den angegebenen Datenbank-Zugangsdaten kann keine Verbindung aufgebaut werden. (das bekomme ich zz ausgespuckt obwohl ich denke ich habe alles richtig gemacht mit phpmyadmin ect.

Wäre es möglich da mit Teamviewer oder so mal rüber zu schauen? Wenn dann erst ab 28. wegen Urlaub oder?


Vielen Dank!
Grüße, Marc

fvdhurk
Beiträge: 46
Registriert: 06.Nov.2014, 12:49

Re: Problem beim Einrichten auf Synology

Beitrag von fvdhurk » 23.Jan.2019, 07:43

Guten Morgen,

vielleicht liegt es

1.) an der Port-Einstellung. Da im allgemeinen auf der Diskstation MariaDb installiert ist, würde ich mal den Port 3307 versuchen.
2.) Sollte auf der Diskstation die Firewall aktiviert sein, muss der Port in der Firewall auch noch explicit freigegeben werden.

Ich hoffe es hilft ein bisschen weiter. Bei mir läuft Open3a auf einer Synology DS218+.

Gruß Frank

Support
Administrator
Beiträge: 3059
Registriert: 24.Okt.2007, 23:59

Re: Problem beim Einrichten auf Synology

Beitrag von Support » 23.Jan.2019, 15:52

Hallo Marc,

ich sehe es mir gerne während der Hotline-Zeiten per AnyDesk an, weil ich kenne die Synology leider nicht auswendig ;)

Wurde der Blog-Eintrag beachtet? https://www.open3a.de/2018/09/open3a-auf-synology-nas

Liebe Grüße
Nena

pat
Beiträge: 1
Registriert: 23.Jan.2019, 17:18

Re: Problem beim Einrichten auf Synology

Beitrag von pat » 23.Jan.2019, 17:21

Hi,

Du brauchst einen SSH Zugang zur Synology und solltest dann ganz genau wissen was Du auf der Synology machst. Sonst kann Dein Support weg sein.

Ich habe es wie folgt zum Laufen gebracht:

DS218+ mit DSM 6.2.1-23824 Update 2

Installation:
PHP 5.6 als Voraussetzung für phpMyAdmin
PHP 7.0
MariaDB 10
Web Station
phpMyAdmin

Konfiguration:
- Web Station
-- Allgemeine Einstellungen
HTTP-Backend-Server NGinx
PHP: PHP 7.0
-- PHP Einstellungen
Profile für PHP 7.0: Erweiterungen curl und mysqli aktivieren

- PHP
Pfad zu MySQL Socket anpassen
in /volume1/@appstore/WebStation/misc/php70.ini
mysqli.default_socket = /run/mysqld/mysqld10.sock

Web Station neu starten
- stop phpMyAdmin
- stop Web Station
- start Web Station
- start phpMyAdmin

- MariaDB
phyMyAdmin Seite laden
https://<URL>/phpMyAdmin/
Einloggen mit MariaDB root Account
Neues Benutzerkonto open3a anlegen, alle globalen Rechte hinzufügen
Neue Datenbank open3a anlegen

- open3a
Verzeichnis erstellen:
/volume1/web/open3A

mkdir 2.9
cd 2.9

list zip file
7z l ../source/open3A_2.9.zip

unzip
7z x ../source/open3A_2.9.zip

chown -R http:http .
chmod -R o-w .

chown http:http system/DBData/Installation.pfdb.php
chmod u+w system/DBData/Installation.pfdb.php

Aufruf:
https://<URL>/open3A/2.9/

Zugangsdaten zur MariaDB:
Host: localhost
Benutzer: open3a

Viel Spaß
Pat
(ohne Gewähr...)

Zahoernchen
Beiträge: 4
Registriert: 17.Jan.2019, 17:13

Re: Problem beim Einrichten auf Synology

Beitrag von Zahoernchen » 23.Jan.2019, 23:28

hey,

vielen dank schonmal für die antworten.
glaube habe schon 1-2 sachen gefunden die bei mir aktuell nicht so sind xD
ich werde es nochmal versuchen.

danke !

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste